Friday, August 30, 2013

Monopolies Suck: Comcast

The wife and I recently moved one 'burb over to Marietta (northwest metro Atlanta). Along the way, I made what turned out to be the colossally-bad decision to sign up for Comcast cable TV. Here's a rundown on what's happened since:

June 28: The initial install, including wiring an outlet for the basement (along the way, the installer refused to run a wire to the upstairs office where internet service was desired, as a result the cable modem is now in the wrong room). The installer’s drill battery ran out of juice halfway through the job. Instead of mounting cable for the basement outlet above ground, he dug out a shallow trench by the foundation and buried half of it, including a connector, with no insulation. He also tried to give me a DVR so old it didn’t even have an HDMI port. Made excuses about getting to work late that morning and being stuck with “whatever was left” on the shelf. I refused the ancient DVR, and rescheduled completion of the install for July 1. The installer left trash and parts all over the yard and basement, and incidentally showed up with one minute to spare in the "two-hour window."

July 1: The most pleasant experience of the entire fiasco. Two techs arrived on time and installed DVRs with no hassles. Unfortunately one of them left with one of my remotes in his pouch, and neither of them bothered to check the existing splitter, lines, or grounds. This would be significant later.

August 7: All service dropped out.

August 8: Service call, tech showed up fifteen minutes after expiration of the "two-hour window." He replaced a splitter, replaced the ground block, and ran new ground wire to electrical box (previous ground was wired to a plastic water pipe--nice). You would have thought all that would have been done during at least one of the prior installation visits. Tech replaced an old DVR in living room with a newer model (Motorola DCX3400), which worked for 24 hours. Unfortunately…

August 9: … all HDMI ports on my Pioneer VSX-921 receiver failed the next day. A little research revealed that the Motorola DCX3400 DVR has well-known deficiencies with implementation of the HDCP handshake, and has been known to “brick” customer hardware. After much thrashing with Comcast customer no-service (including a Comcast no-show for a service call that I left work to wait for--another fine example of the "two hour window"), the local service manager, offered a $400 service credit in lieu of filing an insurance claim to pay for the destroyed receiver. I reluctantly agreed.

But for future reference, if you do make the error of signing up for Comcast, UNDER NO CIRCUMSTANCES SHOULD YOU ALLOW A MOTOROLA DCX3400 DVR IN YOUR HOME. IT MAY WELL DESTROY YOUR PROPERTY. It is simply unconscionable for Comcast to be putting that kind of garbage gear out there, with not even a hint of a warning.

August 18: After that fiasco, I removed the Comcast DVR from the living room and bought a Tivo Premeire (not only are Comcast’s DVRs destructive, they appear to have been programmed in the mid-1990’s; it's a terrible device with lousy software). I called the local Comcast store twice to check on their stock of Cable Cards, and was assured they had “plenty.” Went to the store, after a 30-minute wait was issued a Cable Card and told it would be “the one you need” for a Tivo. Upon getting home, I found out the card I’d been given was a single stream card that does NOT work with a Tivo. By now the Comcast store had closed for the day.

August 19: Took the faulty card back to the Comcast store. Waited another half-hour, only to be told “we ain’t got that” in terms of an multiple-stream M-Card, which is required for a Tivo. Why I’d been given the wrong card in the first place, no one could answer. I was told an M-Card might be available by the end of the week.

August 23: Picked up an M-Card after another long wait.

August 29: This was when I discovered that multiple HD channels, including ESPN HD, are not available on the downstairs connection. This was not well-received on the first day of football season. Went through the usual “sending signals” script with customer no-service, to no avail. Research indicates the error message (S0a00) is due to inadequate wiring. That’s funny, I could have sworn my wiring had been (a) just installed for that outlet in June, and (b) just re-checked by another tech in July. Given that Comcast charges $60 for a service call (something I found out by checking my billing online--not one single Comcast employee has ever mentioned this charge at any point during my brief time as a customer), I refused the “offer” of yet another service call--which presumably I would have been charged another $60 for.

Enough is enough. Expensive service is NOT worth this level of hassle and incompetence. I absolutely refuse to wait around hours for a “service call” that may never arrive. Today their "executive customer service" rep couldn't even commit to a time certain for a repair stop.

That's it. "Service" that's expensive, unreliable, and even outright destructive is not worth this much hassle. Comcast, you're fired.

UPDATE: After I finally got some time this evening, I located the problem. There were two sets of splitters coming off the main line. One was needed; it feeds the cable modem and both TVs. The other, upstream of that splitter, fed a coax in the kitchen that we don't use. I bypassed that splitter with an inline adapter, and bang, everything works now.

Not one of the three sets of techs who've been to my house bothered to ask whether we were using the line coming out of the superfluous splitter. Not one of them bothered to check the signal level at the basement TV (the lack of signal, thanks to the double set of splitters, was the problem there). The last tech actually replaced the unneeded splitter, without ever asking whether we actually use the extra line it's in there for (we don't).

Pathetic. But at least I have ESPN back for the weekend. I think I'll still fire Comcast; the aggravation of another couple of months like this will take years off my life...


  1. Wow.

    What took you so long?

    Seriously, I cut the cable this past year. FWIW, I found that CenturyLink is equally incompetent as Comcast, but after several months of effort, I finally got those screwups fixed. I'm only getting ~5 Mbit/sec, but that seems plenty fast for browsing and I seem to be able to stream HD video over my iTV without problems.

    Now I forget - why did I think I needed cable TV?

  2. My apologies for the poor experience. It appears that there are many issues to address based on post. I will reach out to our local leaders to ensure that your concerns are addressed. Please email us at, provide your account info, contact number and a link to this page for reference).

    Thanks for providing the opportunity to assist.

    Comcast Corp.
    National Customer Operations

  3. Thanks for sharing, wow that's crazy. I have Comcast Cable in Baltimore, MD and haven't had any problems (knock on wood) but you should go to their local store and complain to the manager?